[owncloud-devel] Undelete not working with Swift backend

Shane H. Wilson shane at centre.edu
Wed Apr 1 01:44:51 GMT 2015


I'm testing ownCloud for deployment at a College using OpenStack Swift as the primary back-end storage.

ownCloud 8.0.2, Apache 2.4.7, PHP 5.5.9, OpenStack Swift (Juno), Active Directory for accounts.

I have it set up and I've been testing with a small group using disposable data. Just today I tried deleting some data and then going to the "Deleted Files" link in my account. Nothing showed up. I also logged in as the local admin account and deleted on of the help files that came with my account with the same result.  I deleted some large files out of my account and checked the space used on my Swift storage and it appears they where deleted and not kept for "undelete".

I asked about this on the forums and was pointed at an 8 month old bug report.  Is this something that is being worked on?  I've been working on using s3ql to mount my swift storage to the OS as a backup plan, but I've been having issues getting it to work correctly so I thought I would ask in dev about it.

Thanks!

Shane Wilson
Information Technology Services
Senior Systems and Networks Coordinator

CENTRE COLLEGE
Personal education. Extraordinary success.
http://www.centre.edu<http://www.centre.edu/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.owncloud.org/pipermail/devel/attachments/20150401/b844120d/attachment.html>


More information about the Devel mailing list