[owncloud-devel] Url Loop in OC 8.1

Lukas Reschke lukas at statuscode.ch
Fri Sep 4 11:06:16 GMT 2015


> On Sep 4, 2015, at 1:01 PM, Jose Luis Algara <osotranquilo at gmail.com> wrote:
> 
> Hello.
> 
> My name is Jose Luis. 
> I'm starting to develop a new application for owncloud, and I can not do something basic.... open a new url.
> 
> I read everything I could before making the query here, appreciate some help to get started.
> 
> My code:
> 
> In routes.php
> 
> return [
>     'routes' => [
> 	   ['name' => 'page#index', 'url' => '/', 'verb' => 'GET'],
> 	   ['name' => 'page#codigo', 'url' => '/codigohoy', 'verb' => 'GET'],	
>     ]
> ];
> 
> 
> In pagecontroler.php
> 
> 	public function codigo() {
>         return new TemplateResponse('hucodigos', 'codigo');
> 	}

I suppose you need to disable the CSRF protection here (“@NoCSRFRequired”), but please do this on view only controllers ;-)

- Lukas

> 
> In codigo.php Basic HTML
> 
> The problem is that while attempting to open the address /owncloud/index.php/apps/hucodigos/codigohoy the browser goes into a loop and displays an error ( ERR_TOO_MANY_REDIRECTS ) page instead. 
> In Chorme I can see that the generated URL is: http://localhost/owncloud/index.php?redirect_url=%2Fowncloud%2Findex.php%2Fapps%2Fhucodigos%2Fcodigohoy <http://localhost/owncloud/index.php?redirect_url=%2Fowncloud%2Findex.php%2Fapps%2Fhucodigos%2Fcodigohoy>
> 
> Thanks a lot for the help.
> _______________________________________________
> Devel mailing list
> Devel at owncloud.org
> http://mailman.owncloud.org/mailman/listinfo/devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.owncloud.org/pipermail/devel/attachments/20150904/9235301e/attachment.html>


More information about the Devel mailing list