[owncloud-devel] Bug#815963: Warn users about unsupported upgrade path

Joas Schilling nickvergessen at owncloud.com
Fri Feb 26 13:08:55 GMT 2016



Am 26.02.2016 um 13:58 schrieb Chris:
> Furthermore the NEWS file is only telling to use the 8.0.10 from https://people.debian.org/~taffit/owncloud/ where 8.1.5 is also needed before going to 8.2.2
You have to update 7.0.x > 8.0.x > 8.1.x > 8.2.x > 9.0x (to be released 
in march)
>
>> The Debian package is patched to allow it.
>>
>> https://sources.debian.net/src/owncloud/8.2.2~dfsg-1/debian/patches/0009-Don-t-stop-update-over-several-major-versions.patch/
> That is probably something you really shouldn't do. I think there is a reason why this check there is in place.
Exactly, to keep our migration paths short and traceable, we kill them 
after one major release, that is why major jumps (skipping a major) are 
not supported. The problem is, we simply can not have 4 different 
upgrade routines, one from 7.0, one from 8.0, ... etc. and currently the 
upgrade mechanism is not very good in making migrations in steps. (is 
planned for 9.x iirc).





More information about the Devel mailing list